kernal32.dll crashes on 64-bit only? 2012-07-05T05:30:09+00:00

Home Forums Help needed kernal32.dll crashes on 64-bit only?

  • Author
    Posts
  • mrdna
    Participant
    Post count: 220

    Anyone else running the 64-bit version?

    Reason I ask is that I’ve been getting crashes to desktop for several versions now that appear linked to the kernal32.dll. It occurs after I’ve linked several tabbles. (one or a few at a time, not as a large group) Probably between 30 and 50 uses of the link panel.

    This is getting very frustrating as I link about that many new files in on a daily basis so I’m linking along, crash, then have to reload tabbles, find the files that didn’t ‘keep’ the link(s), and do it again. Granted, the files that didn’t keep the linked tabbles is diminishing every, uh, cycle, but it means I’m having to do this a couple times a night.

    Am I the only one seeing this crash? I’d really like to track this problem down, especially if it’s something unique to my system.

  • Andrea
    Keymaster
    Post count: 890

    dear mrdna,

    not sure you are the only one, but I know that Maurizio found the source of this horrible crash: it was lurking into a thread (Tabbles has currently 5 threads running in parallel) and he’s pretty confident the problem is solved (we’re releasing tomorrow as long as nothing gets on the way in the next hours).

    so, just wait until tomorrow! 🙂
    (and thanks for the report OF COURSE!)

  • mrdna
    Participant
    Post count: 220

    Excellent! I’d hoped I’d gave Maurizio enough information in Mantis to squash it, but I was beginning to wonder whether it was actually something unique to my local config and not Tabbles at all. Certainly didn’t want to have Maurizio wasting his time if it was an issue with my machine and not the program.

    Not a problem on waiting now that it’s figured out.

  • Maurizio
    Participant
    Post count: 196

    Hi mrdna,

    unfortunately I’m not sure the problem is solved. It might be fixed in the next version, or it might not.

    When you wrote in Mantis, I thought I was able to reproduce it once, but it may have been another bug which I have now fixed, and which gave the same problem (kernel32 crash). (it was a stackoverflowexception).

    So I don’t really know if I could reproduce it, therefore I don’t know if it’s fixed. If it’s not, I confess I don’t have a clue what else it could be.

    Today we are going to release 1.3.0 and I’d appreciate if you’d let me know if its fixed.

  • mrdna
    Participant
    Post count: 220

    Still occuring. Updated the mantis ticket. :sigh:

    Elsewise things are running quite well, Maurizio. 🙂

  • Andrea
    Keymaster
    Post count: 890

    Hi mrdna,

    but are you using XP 64 or Vista 64?

    Thanks.

  • mrdna
    Participant
    Post count: 220

    Vista 64

You must be logged in to reply to this topic.

We use technology (including cookies) to collect, use and transfer information to support this Site, including for data analytics purposes, as described in this Site's updated Privacy Policy. Your continued use of the Site signifies your acceptance of such cookies. To learn more about how to manage your cookie settings and how to exercise your rights under GDPR please see our Privacy Policy

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close