Ability to use LocalDB with removable disk

Forum > Help needed > Ability to use LocalDB with removable disk

  • @xkat
    Member
    2 months, 3 weeks ago

    Hi all: after buying and using the LAN version (3 machines, only 1 used at a time) for some years, i decided that i needed a portable solution that didn’t depend on the unique disc #.
    Still, the issue i am confronting is regarding the machinename.

    My data location, on any machine, is the portable drive @ A:\AARCHIVE

    Is it possible to subvert the machinename so one doesn’t need to do “rename” query every time one uses a different machine with this set-up?

    i did notice that when i choose DISK INFO (ADVANCED > See which disk contains this file) that “Computer name (optional)” is part of the identification.
    Does that mean that [machinename] can actually be eliminated?
    . . . or . . ‘NULL’ ed ?

    many thanks

  • @Maurizio
    Keymaster
    2 months, 2 weeks ago

    xkat, sorry, I don’t know what you are talking about. πŸ™‚

    unlike tabbles 3, tabbles 4 does not use the unique disk id anymore. it uses paths. in the database, you will have the path A:\foo\bar

    so where’s the problem?

    • This reply was modified 2 months, 2 weeks ago by  Maurizio.
  • @fonetval
    Member
    1 month, 1 week ago

    Hi Maurizio,

    I have just sent a similar message (just before browsing the forum : sorry πŸ™ ) about a “similar” problem.
    I think that the feature of tabbles4 doesn’t do the job on disconneced (but mapped as a local drive letter at file tagging time) volumes.
    In my case, it’s a network installation of only 2 computers (sql server express on a lan machine to which my other computer is connected).
    I’ve make a screenshot to explain (here)The test is the same with a removable media or a local drive of a other machine than the one on wich Tabbles is used : the drive letter isn’t “linked” with the machine name (or volume name for removable media) on which the file is: in both case, it’s the machine name on which I use Tabbles that is displayed as part of the “location attribute” that Tables uses.

    Sorry if there is something I didn’t understand, but : how can I use Tabbles on multiples computers if the centralize database doesn’t identified them in a unique manner ???

    Best regards

  • @xkat
    Member
    4 weeks ago

    Hi, Maurizio — thanks for your reply
    That’s why i put all my data on a portable drive with PATH:
    A:\\AARCHIVE\… etc.
    *Note that my test machine is: “DV7” and the TABBLES database lists files from 3 machines, DV7, Giga2500K, BlueTurtle – all files were resident on the same (single disk id) portable drive, merely ‘referred to’ by different drive letters when used separately on different machines, not networked.

    the problem i experience is that the files are listed by different machinename in the TABBLES4 db and cannot be updated in the interface

    
    SELECT [id],[path],[isDir],[machineName],[idTaggable],[idOrganization]
     FROM [tabbles4].[dbo].[file2]
    
    *,A:\AARCHIVE\6\610\Inspection of foods, medicines.mht,*,DV7,*,*
    *,L:\AARCHIVE\6\614\Sanitary Inspection and control.mht,*,Giga2500K,*,*
    

    Procedure using the TABBLES interface:
    Search (Ctrl F) for “food” > several files are listed (with associated tag: Nutirition)
    (File view NORMAL, with tags, folders, thumbnails]

    
                            A:\AARCHIVE\6\610\Inspection of foods, medicines.mht
    (the 'lost' file) "-"   L:\AARCHIVE\6\614\Sanitary Inspection and control.mht 
    

    then: right-click > “Locate in windows explorer” > “Specify current location”,
    and successfully “Files Found:” > “Update the tags to point to . . . ”
    “Info – files were found and . . . ”
    Close interface; repeat search; file still shows previous location “L:\”
    and has not been updated.

    Curiously, right-clicking “Info” when hovering over ‘lost’ filename shows ‘date mod:’ and ‘size:’ are empty, but “Computer: DV7” even though the db always lists machinename: Giga2500K

    please advise

    many thanks

You must be logged in to reply to this topic.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close