Tabbles 1.3.5 is out: please test! 2012-07-05T05:30:53+00:00

Home Forums General discussion Tabbles 1.3.5 is out: please test!

  • Author
    Posts
  • Andrea
    Keymaster
    Post count: 880

    Hello everybody!

    This release is mostly about bug fixing. We also abandoned the double installer (32bit and 64bit). There are still a few things that we’re not sure about, in particular:

    Windows 7 (32 bits):
    – the shortcuts don’t work, and we have no idea why. Probably the installer is to blame at 100%
    – the shell-extension (right click on a file in Windows Explorer and see "tag file") doesn’t alway install/work. Crazy shit, next to paranormal.

    Vista 64bit (presumably also Windows 7 64bit):
    – when installing, Explorer starts crashing and restarting… restarting the PC seems to solve this.

    Believe it or not, all of this is due to the crappy Windows installer. We need to get rid of it and move to something more serious, but we couldn’t make it for this press deadline…

    Please post bugs/comments/insults on getsatisfacion

    —-> THANX <—– :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen:

  • NGKII
    Participant
    Post count: 16

    Hi!

    Just installed Tabbles 1.3.5. I attempted to add a wallpaper. When I added the wallpaper it needed to be resized. However, I noticed that all the Tabbles icons were reduced to an unrecognized size on the wallpaper. I then resized the wallpaper to fit within the Tabbles window. This worked successfully. I then locked the wallpaper. However, the Tabbles icons in the window remainded at an unrecognizable size. Using my cursor I attempted to highlight the icons in the hope of making them larger by holding down the right mouse button. When I did so and moved the mouse the wallpaper moved (I thought it was locked and it shows locked!). When I used the resize tools (Bar and round button) it made the icons on the screen larger. However, it also greatly enlarged the wallpaper so that the window looked as if it were a single color instead of wallpaper. I’m going to remove the wallpaper for now.

    Hope this helps!

  • Andrea
    Keymaster
    Post count: 880

    hello!

    yes, we need to improve this… it’s one out of many little details that needs improvement 😀

    thanks!

  • mrdna
    Participant
    Post count: 220

    "Andrea" wrote:
    Vista 64bit (presumably also Windows 7 64bit):
    – when installing, Explorer starts crashing and restarting… restarting the PC seems to solve this.

    Did not experience this under Vista 64. Install went fine and everything came back up just fine.

  • NGKII
    Participant
    Post count: 16

    Hi!

    Can’t seem to get into getsatisfaction. Says it doesn’t recognize my email address and can’t find an option for setting up an account! I installed the new 1.3.5 and it seems to run very slow when you open a drive icon and this is particularly true if you scroll the files or folders on the drive. I’m assuming that Tabbles does not index these files. The folder on my drive has 1,511 files.

    Thanks!

    Nick

  • Andrea
    Keymaster
    Post count: 880

    Hi Nick,

    is this version slower than the previous one? The changes we introduced that may have slowed-down is the fact that now Tabbles reads date and size, and this requires some extra reading of the disk. Maurizio knew that this might have slow down a bit…

    I’ll forward him this (he’s currently fighting to re-install Win7).

    thanks! 🙂

  • mrdna
    Participant
    Post count: 220

    I noticed the one-click pop-up took an extra second or 2 to pop after adding a file. For me, other than that seems relatively ok.

    BTW, explorer did start to crash when bringing it up this morning. Reboot seemed to clear it up.

  • Andrea
    Keymaster
    Post count: 880

    @Nick are you sorting the files by last modified? That one is particularly slow and soon we’ll add a pop-up to warn you about this.
    Also, is it slowing down before the files are being shown or while they’re being shown (and the files appear slowly…)?
    If the first case is true, than the slow-down is connected to the sorting by date.
    No, we’re not indexing the files, if we did we’d need to grow the db (and use more ram) or to read/write the db from a file (and this is would slow down badly…right now the whole db is alway loaded in memory and it’s written on the disk only to save/back-up.

    @mrdna what a keen eye! 😀 This is indeed a part of making the rules engine smarter. This trick (as far as I understand) is used because the engine is waiting for a couple of secs to see if the user renames the file: if the file is renamed within that time, only one pop-up comes up instead of 2 (one for the file with the original name and one for the file after being renamed) which might be perceived as bug. This is useful when you create a file/folder from the right-click menu and then you rename it straight away.

  • NGKII
    Participant
    Post count: 16

    Hi Andrea!

    In my case it seems much slower. However, I’ve just recently started to use the software on a frequent basis and I’m somewhat reluctant to use it has my primary filing system at this point.

    Thanks!

    Nick

  • Maurizio
    Participant
    Post count: 196

    "NGKII" wrote: Hi Andrea!

    In my case it seems much slower. However, I’ve just recently started to use the software on a frequent basis and I’m somewhat reluctant to use it has my primary filing system at this point.

    Thanks!

    Nick

    NGKII, Sorry for the incovenience. I need to know if the delay happens before the files are drawn, or while the files are being drawn. In other words, do you wait many seconds before you see the first file, or is there a long delay between one file and another?

    Also, are you sorting files by "date modified"?

  • NGKII
    Participant
    Post count: 16

    Hi!

    I’m opening a drive. The window then opens displaying the folders/files on the drive. This takes several seconds. When the scroll directional appears I click on it to show the next screen of folders/files. This takes more seconds, etc. I’m not doing any sorting.

    Nick

  • Maurizio
    Participant
    Post count: 196

    "NGKII" wrote: Hi!

    I’m opening a drive. The window then opens displaying the folders/files on the drive. This takes several seconds. When the scroll directional appears I click on it to show the next screen of folders/files. This takes more seconds, etc. I’m not doing any sorting.

    Nick

    In the file window, please open the "view" menu, and tell me which of the following options is checked:

    • Name
      Files with more tabbles
      Files with fewer tabbles
      Recently opened with Tabbles
      Date modified
      Recently tagged

    Also: What kind of drive is it? Is it an hard disk?

    Do you happen to have network drives?

  • NGKII
    Participant
    Post count: 16

    Hi!

    Only "Name" and "Normal".

  • Maurizio
    Participant
    Post count: 196

    Ok. What kind of drive is it ? Is it an hard disk or a removable drive or a network drive?

    and do you have any network drives at all? Thanks

  • NGKII
    Participant
    Post count: 16

    Hi!

    It is an external (USB 2.0) 160GB Western Digital Drive. No network drives. I do have an additional USB Flash Drive (16GB) and USB external drive (60GB) attached as well. However, I’m not attempting to access the later two drives.

    Nick

  • Maurizio
    Participant
    Post count: 196

    "NGKII" wrote: Hi!

    It is an external (USB 2.0) 160GB Western Digital Drive. No network drives. I do have an additional USB Flash Drive (16GB) and USB external drive (60GB) attached as well. However, I’m not attempting to access the later two drives.

    Nick

    Thanks. If you enter a hard disk drive (such as C:), does it seem faster?

  • NGKII
    Participant
    Post count: 16

    Hi!

    Yes, however, there are only 70 items vs 1,500 plus items on the external drive.

    Nick

  • Maurizio
    Participant
    Post count: 196

    "NGKII" wrote: Hi!

    Yes, however, there are only 70 items vs 1,500 plus items on the external drive.

    Nick

    Since you told me that the delay does not happen before the first file is drawn, but between one file and another, then the number of files should make no difference.

    So my guess is that this is a particularly slow drive, and, since in the latest version I read the file date and size each time I draw a file, drawing the file window has become slower.

    I will do some changes to bring back the previous behavior, but it will take a few days.

  • Maurizio
    Participant
    Post count: 196

    Could you make this last test? in the external drive, enter a subfolder which contains fewer files (e.g. 40 files), but enough to fill the file window. (Say, 80 files.) And tell me if the redrawing of files in this subfolder is as slow as in the root directory. Thank you.

  • NGKII
    Participant
    Post count: 16

    Hi!

    The external drive runs at 5400 RPM.

    Nick

  • NGKII
    Participant
    Post count: 16

    Hi!

    I did as instructed. I created a folder with about 80 files and folders. I don’t see much if any difference in the speed. However, there might be some difference.

    I did the same test on the USB Flash Drive (16GB) and it seems much faster. I also tried the test on an "older" external HDD and it did seem slower than the Western Digital 160GB external drive.

    Nick

  • NGKII
    Participant
    Post count: 16

    Hi!

    Additional note on another subject. I tested the Replace the desktop under "Options". I use dual monitors and the "primary" monitor desktop was replaced. However, the secondary monitor wallpaper remained unchanged. Would be nice to have Tabbles as the desktop.

    Nick

  • Maurizio
    Participant
    Post count: 196

    "NGKII" wrote: Hi!

    Additional note on another subject. I tested the Replace the desktop under "Options". I use dual monitors and the "primary" monitor desktop was replaced. However, the secondary monitor wallpaper remained unchanged. Would be nice to have Tabbles as the desktop.

    Nick

    Thanks for the feeeback.

    I think it is urgent to allow to put files on Tabbles’ desktop (AKA main window). Until then, Tabbles is not ready for the desktop. Dealing with secondary monitors is important but less urgent.

  • mrdna
    Participant
    Post count: 220

    I don’t know if this applies at all, but I’m seeing intermittent slow-downs in redraws, sometimes to the point where one or all of the windows show as not responding (and go black) for a few to several seconds at a time. There -is- a definite lag in response when tagging and, more often than not, a significant lag (2-plus seconds) when creating a new tabble in the quick-tag window.

    Thinking it might be related to memory I opened the task mgr and ran Tabbles through a few tests. (haven’t done it in a while) What I found:
    Tabbles at boot – 75-110k (about what it’s been for several versions)
    file window open – 120-150k (also about what I’ve seen before)
    quick-tag open – 180-200k (a little high, but not out of the ordinary)
    adding tabbles in quick-tag – 180-350 (!)
    creating new tabble – 200-500k (!!)

    I don’t know why the wide variation in RAM use, but lag does go up the higher RAM used. (I know – duh, mrdna…) I did see the program give up RAM several times; there were several drops from about 300k to 180k or so when playing in the quick-tag window, but some RAM seems to be retained (?).

    Right now Tabbles is minimized and using around 310k. Before I closed the program to reboot it and collect this data it was up over 400k!

    ((Just did another quick-tag – ram use up over 400k during, back down and steady at 370k. quick-tag again, ram down and steady at 290k. oy…))

    Hope this helps.

    (vista64, AMD 2.2ghz dual, 4g RAM, 7200rpm sata)

  • inf2know
    Participant
    Post count: 17

    installation of 1.3.5 (dated 1203) has really messed up my desktop so this is from my backup machine.
    I just installed 1.3.5 and noticed many very disturbing activities.
    1. my desktop was totally replaced and really messed up with what appeared to be a tabbles background as well as TOTALLY re-arranging the desktop ICONS.
    2. It appears that My default Firefox was changed to IE
    3. I can not even start control program to Uninstall tabbles!!!!!
    4. Snagit no longer works so I can not even send a print screen.
    5. there is not even a "run" ability

    This install on Vista has really screwed me!!!!!

  • Andrea
    Keymaster
    Post count: 880

    @mrdna thanks for the feedback! We didn’t do a lot of work on optimizing the ram… we need to do it at some point… please keep posting info about it cause the more we know the better. FYI, I have Tabbles always open on WinXP and currently it’s eating 120MB (I have about 8K files in the db).

    @inf2know OMG, this sounds like a mess… it’s a mistery how this could be related to the Tabbles installation… 😐
    We didn’t hear this from anybody else…If I’m not asking too much, could you please try with the 1.3.8?

    thanks guys, your feedback is much appreciated!

    A.

  • inf2know
    Participant
    Post count: 17

    1.3.5 (on my 32-VISTA Machine) has really messed up my Vista ultimate machine.
    Decided to reboot and much to my VERY pleasant shock, it booted normally so will be able to uninstall Tabbles 1.35!!!

    If someone can tell me how to export event viewer files I will do that and then upload.
    This (needless to say) is a CRITICAL problem! and has stopped me from further use of Tabbles.

    Before the Uninstall I will create a system restore point…
    Looks Like I am able to uninstall Tabbles 1.35 and will then reboot.
    At least It does not appear that I will have to go to recovery mode.

    The interesting piece of information is that the uninstall opened Firefox but Firefox said that it was not the default browser and asked if I wanted to change that. I believe Tabbles 1.35 changed the following:
    1. Desktop
    2. security access controls
    3. Default browser to IE
    4. I thought I was "current" on .net but I believe 1.35 installed some type of inet update and I believe it was an older version.

    Currently rebooting and all seems OK…..

    SUGGESTION to READERS. Do a Backup (or create a system recovery point) BEFORE updating Tabbles!
    [email protected]

  • mrdna
    Participant
    Post count: 220

    inf2know,

    Just a few things as what you are describing is -very- unusual… I run Vista 64, fyi. (you run ultimate in 32-bit??)

    "inf2know" wrote: 1.3.5 (on my 32-VISTA Machine) has really messed up my Vista ultimate machine.
    Decided to reboot and much to my VERY pleasant shock, it booted normally so will be able to uninstall Tabbles 1.35!!!

    If someone can tell me how to export event viewer files I will do that and then upload.
    This (needless to say) is a CRITICAL problem! and has stopped me from further use of Tabbles.

    Before the Uninstall I will create a system restore point…
    Looks Like I am able to uninstall Tabbles 1.35 and will then reboot.
    At least It does not appear that I will have to go to recovery mode.

    The interesting piece of information is that the uninstall opened Firefox but Firefox said that it was not the default browser and asked if I wanted to change that. I believe Tabbles 1.35 changed the following:
    1. Desktop
    2. security access controls
    3. Default browser to IE
    4. I thought I was "current" on .net but I believe 1.35 installed some type of inet update and I believe it was an older version.

    Currently rebooting and all seems OK…..

    SUGGESTION to READERS. Do a Backup (or create a system recovery point) BEFORE updating Tabbles!
    [email protected]

    Creating a restore point before installing any program is a good idea. Good reminder there.

    My default browser is firefox and has been for years (currently 3.6b4) and I’ve never seen Tabbles clear it’s default status or re-default IE. I have seen other programs -try-. (specifically written for IE rendering and trying to force load IE) The Tabbles installer should be sending the page request to Windows default browser and shouldn’t ask for a specific browser, but lets windows decide that one. Certainly a curiousity if you’re certain that the FF ‘un-defualt’ happened during the Tabbles install.

    Which brings #2; As vista UAC tosses pop-ups when a program tries to do something above a certain security level, did you get any pop-ups? Part of Vista’s security features is that it won’t let system security happen without your approval. Basically you would have gotten an install failure if Tabbles tried to mess with them and a pop-up wasn’t generated.

    Messing with your desktop… Hmmmm, now there is a desktop replacement feature in Tabbles, but its not default. Being a heavily graphical program I wouldn’t be surprised if Tabbles checked your video resolution (which, as you know, when you change resolution down can really punk your icon set-up). I run 1024×768 and have seen no issue, do you run a higher rezz?

    Curious – did you have a previous version of Tabbles installed by chance?

    Hope this gets sorted out for you.

  • mrdna
    Participant
    Post count: 220

    Ah, found the bug report in mantis and answered a question or two of mine. You have had versions back to 1.2 (and before?) and it looks like you do run a pretty high resolution from the screen shots you sent Maurizio.

    BTW, about the .NET; check in your control panel. The version installed for several releases has been 3.5sp1. It’d be -highly- unusual for windows to allow a step back from that (assuming it installed correctly for you). I remember the fits I had trying to dial back (and keep) directX for a game I play. Control panel will tell you what ver is installed.

  • inf2know
    Participant
    Post count: 17

    I am very happy to report a few events.
    1. After a reboot (1.3.5) my system (desktop and browser) seemed to be back to normal
    2. I was able to successfully uninstall Tabbles and reboot OK
    3. I learned that in event viewer, it is NOT File save as but rather "action" to save (export) event viewer data.
    4. I have sent the logs for review.
    5. I downloaded and installed Tabbles_setup_1.3.8_20091207a.msi (I add the version and data) with NO problems
    6. rebooted and started Tabbles with no visible problems.
    7. sent the Event viewer logs for review (MUCH smaller) since I now understand Event viewer
    8. Probably MOST important is that it Appears Tabbles performs a create system restore point because that in the failing event viewer log.

    (.net 3.5SP1 is installed)

    GOOD Progress….
    [email protected]

  • inf2know
    Participant
    Post count: 17

    I run 1280 x 1024

    Yes, I had previous version installed

  • mrdna
    Participant
    Post count: 220

    woot! Great to know you got things sorted out. Hopefully Maurizio can figure out by your info if Tabbles had some hand in these nefarious happenings. He’s pretty busy at the moment as I understand, but every little bit helps.

    cheers,
    mrdna

  • Andrea
    Keymaster
    Post count: 880

    Gentlemen,

    the issue seemed to be related to our installer restarting Windows Explorer: this won’t happen anymore. I hope that this case is solved 🙂

    cheers,

    A.

You must be logged in to reply to this topic.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close